Rodolfo Bandeira

Rodolfo Bandeira

software, electronics, security, devops, thoughts

How to force phpstorm to use Java JDK 1.7 on MacOS

Screen Shot 2014-11-13 at 6.53.59 PM{.thumbnail}

I decided today to install PhpStorm in my computer at home. So, I found this freaking message. “To open “PhpStorm” you need to install the legacy Java SE 6 runtime.”

Let’s teach you what I did. Just edit this file:

/Application/PhpStorm.app/Contents/Info.plist

On this line, change to use JVM 1.7.

 87       <key>JVMVersion</key>                                                                                                       
 88       <string>1.7*</string>

 

That’s it!

 

Last modified:

LinkedIn
WhatsApp